Magento em versões antigas do PHP

Magento

Um problema comum ao fazer a instalação do Magento é a incompatibilidade com algumas versões do PHP. No exemplo deste caso estamos fazerendo a instalação do Magento 1.9.0.1, PHP 5.2.17 e o módulo do PagSeguro 2.1.

Este foi o erro ocorrido Parse error: syntax error, unexpected T_STRING, expecting T_CONSTANT_ENCAPSED_STRING or '(' in /home/petit/public_html/app/code/local/PagSeguro/PagSeguro/Model/Resource/Setup.php on line 3

Para quem não pode atualizar a versão do PHP, basta fazer a alteração abaixo:

Acesse o arquivo: /app/code/local/PagSeguro/PagSeguro/Model/Resource/Setup.php

de:

<?Php
use Mage_Core_Model_Resource_Setup as Setup;
class PagSeguro_PagSeguro_Model_Resource_Setup extends Setup
{
}

para:

<?Php 
//use Mage_Core_Model_Resource_Setup as Setup;
class PagSeguro_PagSeguro_Model_Resource_Setup extends Mage_Core_Model_Resource_Setup
{
}